Help Wanted: Taxonomy Picker


On SharePoint 2010 you may run into the following error (hell that is a damn lie, you will hit this error eventually if running RTM).

Load control template file /_controltemplates/TaxonomyPicker.ascx failed: Could not load type ‘Microsoft.SharePoint.Portal.WebControls.TaxonomyPicker’ from assembly ‘Microsoft.SharePoint.Portal, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c’.

It looks like this in your Application Event Log:

UPDATE:: After doing this fix I received this error again. I checked the Microsoft.SharePoint.Portal assembly and did not find the TaxonomyPicker class!!! So to fix this you may want to rename TaxonomyPicker.ascx to TaxonomyPicker.ascx_broken so we do not try to recompile it each time the AppPool is started. The user control is never used within SharePoint and therefore serves no real purpose.

If you assumed you configured something incorrectly; don’t, its a bug in SharePoint – the good news is you can actually fix this one yourself.

  1. Navigate to /14/TEMPLATS/ControlTemplates/TaxonomyPicker.ascx user control
  2. Open the user control in a text editor and locate the first line
  3. Find the character string , and replace with a comma ‘,’ (without quotes).
  4. Save the user control and you have completed fixing this bug

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s